Scheduling ( Two Smart watering levels; Smart disabled)

Netro Support
Updated at 2023-06-09 06:07:25 UTC
Topic: Smart Watering

There are 2 different levels of Netro’s smart watering you can choose (For Netro watering controller, please go to Settings->Zones->Smart Zone; for Netro Pixie timer, please go to Settings->Garden->Smart Zone)

 1. Smart watering: Level advanced

This is the default setting of Netro watering controller's smart watering. In this level, your zones will be watered automatically by Netro with smart schedules.

Netro will do everything for you, you do not need to set up the program/schedule.

Netro will skip smart watering and programs when there is large amount of rain(>0.2inch/ 5.08 mm) or watering regulations and manual restrictions.

You can inspect the Smart schedules in the calendar view. They are with the blue water-drop icons.



2.Smart watering: Level basic

This is the default setting of Netro Pixie timer's smart watering. In this level, no smart schedule will be generated. You will need to add programs manually (go to Settings->Programs to add programs) and Netro will skip programs when there is large amount of rain(>0.2inch/ 5.08 mm) or watering regulations.

 If you do not want smart zone schedule to override your own programmed schedule, you can set up the Smart Zone level from Advanced to Basic, which only skip rainning days for your programmed schedule.

Please note when smart zone is enabled, your local regulations will automatic override your own program if there is any conflict. So when you set up your own program watering time, please do not conflict with your local Regulations if there is any. To check up regulations, please go to Settings->Regulations.



3.Smart-zone feature disabled

If you want to create your own programs and turn off smart zone feature and rain delay feature, go to Settings->Zones->Smart Zone (Settings->Garden->Smart Zone for Pixie Timer) and toggle the enable button. When the smart zone is disabled, the system will strictly follow the user program to water the zones. There is no intelligence here. Netro will not skip your schedules when there is rain. Regulation feature will not be in effect as well.

View: 10711    Follow: 2    Like: 1

2019-07-04 06:17:04 UTC  
I really want to use the Advanced level but it recommends that one of my cycles (Plants) run for 49 minutes twice! That's between 4 and 6 am. Why does it recommend 49 minutes? Seems to me that it is too much water. I switched it to Basic in the meantime.
Netro Support
2019-07-05 08:37:09 UTC  
Dear customer,

Netro calculates the smart schedules also based on environmental conditions including the soil type, sprinkler types, etc. If you select Dripper/emitter for your zones, it might have longer watering duration than other zones as dripping/emitter system is really slow in moving watering to the ground.

Netro Support

Julian Hansen
2019-08-02 07:01:09 UTC  
Could you allow users to set a maximum time when smart watering? I have found if my drippers run for more than 15 minutes my terrace is flooded, but Netro wants to run for 28 minutes.
Netro Support
2019-08-05 05:45:03 UTC  
Hi Julian,

Netro's algorithm is based on expert gardening knowledge, one of which is to avoid watering equally everyday and instead to water less frequently but deeply. Netro waters your garden only when the soil is dry enough in order to draw more oxygen into the roots, leading to a lusher landscape.

Currently Netro does not allow users to set a maximum time. However, you can customize the smart watering. To adjust smart watering, please go to settings->zones->select a zone->smart zone and choose your preferred watering mode. We recommend you to choose eco mode to decrease the watering duration. You can choose "customized" mode to adjust watering by providing the preferred moisture level and flow rate of your sprinklers.

Netro Support

Kiran Tuniki
2019-09-04 23:07:13 UTC  
When I have enabled smart watering, Netro schedule is skipping for next 5 days, and it is only watering on Monday and Tuesday. I noticed that Netro did not water my plants this morning, so I had to manually run my program cycle. I turned off smart schedule, it still shows that Netro will not water my plants until next Monday. Seems strange. Do I have to manually water everyday?
Netro Support
2019-09-05 05:34:20 UTC  
Hi Kiran,
Your smart watering is limited on Monday and Tuesday because there's water regulation in your area that watering is limited to two days a week. Please go to Setings->Regulations to check and you can disbale this regulation.

Netro Support

Lou Infeld
2020-04-19 13:52:42 UTC  
The advanced level of Smart watering wasn't working well for me, so I turned alll the zones to the basic level and set up a manual schedule. Netro started using my manual schedule. However, it also used a Smart schedule. I then turned off Smart watering completely from all my zones. Netro still used a Smart schedule. I pulled out my 3 Whisperers. Still Smart watering. I deleted my Whisperers from the App and am now waiting to see if only my manual schedule works.
Netro Support
2020-04-23 02:02:26 UTC  
Hi Lou,

If you turn off the smart zone frature, there is no intelligence here. Could you please send your screenshots to and we will check.

Netro Support

2020-04-21 06:08:25 UTC  
I have specified the running time for each zone. How do I make sure Netro does run entire time in one go? Because it will cause the water to run off.
Netro Support
2020-04-23 02:00:29 UTC  
Hi Hitesh,

If you create a program, Netro will strictly follow the watering time for your program so Netro will not break your watering into pieces. We suggest you create multiple programs to avoid runoff.

You can try Netro Smart watering. Netro calculates the smart schedules based on other environmental conditions including the soil type. If you select clay, clay loam or loam as the soil type which accepts water slowly, often as little as 1/4 inch per hour, Netro will break the watering into many pieces to avoid water runoff.

2023-07-13 12:45:34 UTC  
We currently have restriction in place and can only water once on Tuesdays and Fridays. When the smart feature is enabled, it waters twice a day, every day. How do I make it follow the program?
Wency Pan
2023-08-07 05:36:53 UTC  
Dear customer,

Could you please send us email to with your Netro account registered email?
We will have our technician look into this issue. 

Netro Support